Database Overload ทำให้ร้านค้าไม่สามารถเข้าใช้งานได้ชั่วคราว
Incident Report for Page365
Postmortem

🇹🇭 สาเหตุที่พบปัญหา
ทีมพัฒนาได้ Implement เพื่อแก้ไขปัญหาบางร้านค้าไม่ได้รับ Norification บน Mobile ระหว่างที่ Roll out 50% พบปัญหา Database ทำงาน Overload ทำให้ร้านค้าทั้งหมดไม่สามารถเข้าใช้งานระบบได้ในช่วงเวลาดังกล่าว

เวลาที่พบปัญหา
วันที่ 28/11/2022 เวลา 11:06 - 11:20 น.

วิธีแก้ปัญหาระยะสั้น
ทีมพัฒนาได้นำโค้ดส่วนที่ก่อให้เกิดปัญหาดังกล่าวออกจากระบบแล้ว

วิธีแก้ปัญหาระยะยาว
ทีมเทคนิคจะเพิ่มระบบตรวจจับการทำงานที่ผิดปกติของฐานข้อมูล และส่งเรื่องให้ทีมพัฒนาแก้ไขโดยเร็วที่สุด


🇬🇧The root cause of the incident
The development team has upgraded the code base to solve the problem that some users do not receive Notifications on Mobile during the 50% rollout. The database was overloaded, causing all stores to be unable to access the system during that time.

Incident Time
28/11/2022 12:06 - 12:20 pm. (GMT +08:00)

Short term solution
The development team has removed the code that caused the problem from the system.

Long term solution
The technical team will add a system to detect malfunctions in the database. And send the matter to the development team to fix it asap.

Posted Apr 05, 2023 - 11:56 GMT+07:00

Resolved
🇹🇭 สาเหตุที่พบปัญหา
---
ทีมพัฒนาได้ Implement เพื่อแก้ไขปัญหาบางร้านค้าไม่ได้รับ Norification บน Mobile ระหว่างที่ Roll out 50% พบปัญหา Database ทำงาน Overload ทำให้ร้านค้าทั้งหมดไม่สามารถเข้าใช้งานระบบได้ในช่วงเวลาดังกล่าว

เวลาที่พบปัญหา
---
วันที่ 28/11/2022 เวลา 11:06 - 11:20 น.

วิธีแก้ปัญหาระยะสั้น
---
ทีมพัฒนาได้นำโค้ดส่วนที่ก่อให้เกิดปัญหาดังกล่าวออกจากระบบแล้ว

วิธีแก้ปัญหาระยะยาว
---
ทีมเทคนิคจะเพิ่มระบบตรวจจับการทำงานที่ผิดปกติของฐานข้อมูล และส่งเรื่องให้ทีมพัฒนาแก้ไขโดยเร็วที่สุด



🇬🇧The root cause of the incident
---
The development team has upgraded the code base to solve the problem that some users do not receive Notifications on Mobile during the 50% rollout. The database was overloaded, causing all stores to be unable to access the system during that time.

Incident Time
---
28/11/2022 12:06 - 12:20 pm. (GMT +08:00)

Short term solution
---
The development team has removed the code that caused the problem from the system.

Long term solution
---
The technical team will add a system to detect malfunctions in the database. And send the matter to the development team to fix it asap.
Posted Nov 28, 2022 - 11:00 GMT+07:00