🇹🇭 พบปัญหาขัดข้องทางเทคนิค / 🇬🇧Currently there was a technical issue.
Incident Report for Page365
Postmortem

🇹🇭 สาเหตุที่ระบบขัดข้อง
ทีมเทคนิคพบว่ามีหนึ่งในเครื่อง Server ที่ไม่ตอบสนอง ทำให้ Job ที่ต้องถูก Process ด้วย Server ดังกล่าวไม่ทำงาน ส่งผลให้ระบบแคชไม่สามารถอ่านข้อมูลได้เนื่องจากมีข้อมูลค้างมากเกินไป ส่งผลให้ระบบอื่น ๆ ล่ม

ช่วงเวลาที่ได้รับผลกระทบ


วิธีแก้ไขปัญหาระยะยาว
ทีมเทคนิคได้เพิ่มเงื่อนไขการตรวจจับให้กับ Server ทุกตัวให้ Restart ตัวเองหากว่าไม่ตอบสนองเรียบร้อยแล้ว

ช่วงเวลาที่ได้รับผลกระทบ
3 ตุลาคม 2565 เวลา 10:24 น. - 11:24 น.

วิธีแก้ไขปัญหาระยะยาว
ทีมเทคนิคได้เพิ่มการตรวจจับหาก Server มีปัญหาจะถูกบังคับ Restart ทันที


🇬🇧 Root cause of an incident
One of our servers is unresponsive, So the job that has to process with that server was stuck and stacked till other services couldn’t read data from the caching system, and the Page365 system was down.

Affected period
Oct 3, 2022, from 11:24 a.m. - 12:24 p.m. (GMT +08:00)

Long term solution
The technical team added a metric that while detecting server fault, it will restart automatically.

Posted Apr 03, 2023 - 14:35 GMT+07:00

Resolved
ขณะนี้ร้านค้าสามารถส่งข้อความและเปิดบิลผ่าน Instagram Direct Message ได้ปกติแล้ว หากว่าร้านค้าใดยังพบปัญหาส่งข้อความหรือเปิดบิลผ่าน Instagram Direct Message สามารถแจ้งปัญหาได้ที่ https://m.me/page365app
Posted Oct 03, 2022 - 11:24 GMT+07:00
Identified
🇹🇭 พบปัญหาเซิฟเวอร์ไม่สามารถเข้าถึงระบบ Caching ได้ ส่งผลให้ร้านค้าพบปัญหาข้อความบน Instagram Direct Message ส่งช้า / ส่งไม่ออก และ หรือไม่สามารถสร้างบิลได้ ทีมเทคนิคกำลังเร่งแก้ไขปัญหาดังกล่าวอย่างเร่งด่วน ขออภัยในความไม่สะดวก

---

🇬🇧There was a problem with the server being unable to access the caching system, resulting in the sellers encountering problems with slow sending / unable to send messages and or unable to generate invoices. The technical team is urgently working to resolve the issue. sorry for the inconvenience
Posted Oct 03, 2022 - 10:24 GMT+07:00
This incident affected: Page365 website (เว็บไซต์).