🇹🇭ระบบขัดข้อง ไม่สามารถใช้งานได้ชั่วคราว | 🇬🇧A technical problem caused a system to temporarily down
Incident Report for Page365
Postmortem

🇹🇭สาเหตุที่ระบบขัดข้อง
ทีมพัฒนาได้ปรับปรุงฐานข้อมูลเพื่อให้รองรับฟีเจอร์ใหม่ แต่ในระหว่างที่อัปเกรดพบปัญหาฐานข้อมูลมีปัญหา Deadlock บางช่วงเวลา ทำให้ระบบไม่อ่าน หรือเขียนข้อมูลจากฐานข้อมูลได้ ส่งผลให้เว็ปไซต์ไม่สามารถใช้งานได้ในช่วงเวลาดังกล่าว

ช่วงเวลาที่ได้รับผลกระทบ
วันที่ 25 สิงหาคม 2565 ช่วงเวลา 21:12 - 21:39น.

วิธีการแก้ไขปัญหาระยะยาว
ทีมเทคนิคจะพิจารณาการทำ Database Sharding เพื่อแก้ไขปัญหา Deadlock ในการอัปเกรดฐานข้อมูล


🇬🇧The reason for the system crash
The development team has updated the database structure to support new features. But during the upgrade, the database encountered a deadlock problem at some intervals causing the system to be unable to read or write data from a database. As a result, the website was down during that time.

Affected date
Wed, 25 Aug 2022 22:12 - 22:39 (GMT +8)

Long term solution
Technical team will consider Database Sharding to fix deadlock in database upgrade.

Posted Sep 27, 2022 - 11:17 GMT+07:00

Resolved
🇹🇭 ทีมพัฒนาได้ปรับปรุงฐานข้อมูลเพื่อให้รองรับฟีเจอร์ใหม่ แต่ในระหว่างที่อัปเกรดพบปัญหาฐานข้อมูลมีปัญหา Deadlock บางช่วงเวลา ทำให้ระบบไม่อ่าน หรือเขียนข้อมูลจากฐานข้อมูลได้ ส่งผลให้เว็ปไซต์ไม่สามารถใช้งานได้ในช่วงเวลาดังกล่าว

ช่วงเวลาที่ได้รับผลกระทบ
วันที่ 24 สิงหาคม 2565 ช่วงเวลา 21:12 - 21:39น.

----

🇬🇧The development team has updated the database structure to support new features. But during the upgrade, the database encountered a deadlock problem at some intervals causing the system to be unable to read or write data from a database. As a result, the website was down during that time.

Affected date
Wed, 24 Aug 2022 22:12 - 22:39 (GMT +8)
Posted Aug 25, 2022 - 21:30 GMT+07:00