ระบบขัดข้องไม่สามารถเข้าใช้งานได้ชั่วคราว
Incident Report for Page365
Postmortem

สาเหตุระบบขัดข้อง เมื่อวันที่ 13 มีนาคม 2562

1. สาเหตุที่ระบบที่ปัญหาในช่วงเช้าเกิดจากเซิร์ฟเวอร์ที่เราได้ขยายเพิ่มในช่วงกลางคืน เพื่อให้สามารถรองรับการใช้งานที่เพิ่มขึ้นของลูกค้าทำงานผิดพลาด โดยได้มีการอัพเดทเวอร์ชั่นของ Docker เป็นเวอร์ชั่นล่าสุดโดยอัตโนมัติ ซึ่งทำให้ container ต่างๆใน Docker ไม่ถูกเรียกใช้งาน ส่งผลกระทบให้ผู้ใช้งานพบปัญหาข้อความไม่อัพเดตใหม่ ส่งข้อความตอบกลับแล้วล้มเหลว หรือไม่สามารถเข้าสู่ระบบได้ ทีมงานใช้เวลา 30 นาที ทำให้ระบบสามารถเข้าใช้งานได้หลังจากที่รับทราบปัญหานี้แต่ก็ยังพบปัญหาสืบเนื่องจากสาเหตุหลักที่แจ้งไปข้างต้น ซึ่งทำให้ผู้ใช้งานพบปัญหาระบบช้า โหลดรูปภาพไม่ขึ้น หรือส่งข้อความออกไม่ได้

แนวทางแก้ไข

  • เพิ่มการตรวจสอบการตั้งค่าโดยผู้เชี่ยวชาญ

  • เพิ่มการแจ้งเตือนเมื่อเกิด Downtime เพื่อให้ทีมงานเข้าดูแลทันทีเมื่อเกิดเหตุการณ์ที่ไม่คาดคิด

2. ผู้ใช้งานที่ดาวน์โหลดแอพ iOS มาติดตั้งใหม่ไม่สามารถเข้าใช้งานได้ ซึ่งเกิดปัญหาจากการอัพเดต Library ที่ใช้งานการพัฒนาแอพ ส่งผลกระทบต่อการแสดงผลหน้า Privacy ผู้ที่โหลดแอพมาใช้งานใหม่ จะพบปัญหาแอพเด้งออก โดยผู้ที่มีแอพใช้งานอยู่แล้ว แต่อัพเดตเป็นเวอร์ชั่นใหม่ จะยังใช้งานได้ตามปกติ

แนวทางแก้ไข

  • ทีมงานทำการแก้ไขเวอร์ชั่น Library และอัพเดตแอพขึ้น Appstore

  • ผู้ใช้งานที่พบปัญหานี้ จะต้องทำการอัพเดตแอพเป็นเวอร์ชั่นใหม่ ซึ่งขณะยังนี้รอการอนุมัติจาก Apple

3. ในช่วงบ่ายเกิดจากระบบบางส่วนของ Facebook เกิดเหตุขัดข้องโดยเฉพาะระบบ Inbox Page ทำให้มีผู้ใช้งานจำนวนมากพยามล็อคอินเข้าสู่ระบบ Page365 เพื่อเชื่อมต่อและตอบข้อความจาก Facebook ส่งผลให้ผู้ใช้งานใหม่จะไม่สามารถดึงข้อความย้อนหลังได้ และการรับส่งรูปภาพ และข้อความ สำหรับผู้ใช้งานแพ็กเกจฟรีจะช้ากว่าปกติ

แนวทาางแก้ไข

  • เพิ่มขนาดฐานข้อมูลเพื่อรองรับผู้ใช้งานที่เข้ามาจำนวนมาก
Posted 12 days ago. Mar 14, 2019 - 17:42 GMT+07:00

Resolved
ขณะนี้สามารถใช้งานได้ปกติแล้ว ขออภัยในความไม่สะดวกเป็นอย่างยิ่ง
Posted 13 days ago. Mar 13, 2019 - 13:41 GMT+07:00
Update
ระบบขัดข้องทำให้ข้อความส่งออกช้า และไม่แสดงรูปภาพ ทีมงานกำลังดำเนินการแก้ไข ขออภัยในความไม่สะดวกเป็นอย่างยิ่ง
Posted 13 days ago. Mar 13, 2019 - 11:51 GMT+07:00
Monitoring
ขณะนี้ทีมงานทำการแก้ไขเรียบร้อยแล้ว ท่านสามารถเข้าใช้งานระบบได้ แต่อาจจะยังพบปัญหาใช้งานช้าหรือหน่วงอยู่บ้างในบ้างร้าน ทีมงานกำลังติดตามสถานการณ์จนกว่าจะกลับมาใช้งานได้อย่างสมบูรณ์
Posted 13 days ago. Mar 13, 2019 - 09:04 GMT+07:00
Identified
ทีมงานกำลังทำการแก้ไขปัญหาการเข้าใช้งานไม่ได้ ซึ่งจะใช้เวลาประมาณ 30-45 นาที คาดว่าจะเข้าใช้งานได้ประมาณเวลา 9.00-9.30 น ขออภัยในความไม่สะดวกเป็นอย่างยิ่ง
Posted 13 days ago. Mar 13, 2019 - 08:21 GMT+07:00
Investigating
ระบบขัดข้องทำให้ไม่สามารถใช้งานได้ชั่วคราว ทีมงานกำลังดำเนินการแก้ไข ขออภัยในความไม่สะดวกเป็นอย่างยิ่ง
Posted 13 days ago. Mar 13, 2019 - 07:58 GMT+07:00
This incident affected: เว็บไซต์ Page365, ระบบดึงข้อมูลจาก Facebook, การเชื่อมต่อ LINE@, ระบบแจ้งเตือนทางอีเมล, ระบบแสดงรูปภาพ, การสร้างรหัส Page365 Express, บิลออนไลน์, and Comment Facebook.